Results 1 to 7 of 7

Thread: Replaced MAF now car dies and gives EPC light... What gives?

  1. #1
    eat-quattro-sleep PRY4SNO's Avatar
    Join Date
    Jul 2007
    Location
    Edmonton
    Posts
    1,883

    Finger Replaced MAF now car dies and gives EPC light... What gives?

    I recently replaced my MAF and twice now while cruising at 75 mph with cruise the car powers out without stalling and throws the EPC light. So I pull over gearing down to brake and the car barely has enough throttle to rev match the downshifts. After cutting the ignition and letting the car rest for about 15-20 seconds it turns over easily and goes for a couple hundred km no problem.

    No MIL lights but I don't have a VAG cable to run a scan. Any suggestions on how to tell if it's the crank position sensor or something else?

    I'm ordering a Samco hose kit lickety split, any chance it's a bad DV?
    Find me on Instagram @pry4sno

    Candy White 2010 VW Golf Sportwagen TDI 6 speed /// #farmenwagen
    Indigo Pearl Effect 1992 80q 20v /// Eventual AAN'd Winter Sled
    Brilliant Black 1990 Coupe quattro /// Because Racecar

  2. #2
    Registered User VWSM's Avatar
    Join Date
    Mar 2006
    Location
    CALGARY
    Posts
    1,362

    Default Re: Replaced MAF now car dies and gives EPC light... What gives?

    LOL same problem shitty brake switch.

  3. #3
    eat-quattro-sleep PRY4SNO's Avatar
    Join Date
    Jul 2007
    Location
    Edmonton
    Posts
    1,883

    Default Re: Replaced MAF now car dies and gives EPC light... What gives?

    Hmmm... someone suggested that on the 'zine but same too for the crank position sensor and also long term fuel trims (VAG-COM block 032) being off due to previously faulty MAF readings, simply requiring a code clearing to fix.

    Who's right?
    Last edited by PRY4SNO; 02-06-2010 at 10:22 AM.
    Find me on Instagram @pry4sno

    Candy White 2010 VW Golf Sportwagen TDI 6 speed /// #farmenwagen
    Indigo Pearl Effect 1992 80q 20v /// Eventual AAN'd Winter Sled
    Brilliant Black 1990 Coupe quattro /// Because Racecar

  4. #4
    General Bad Ass Mantis's Avatar
    Join Date
    Apr 2008
    Location
    Calgary
    Posts
    1,383

    Default Re: Replaced MAF now car dies and gives EPC light... What gives?

    Block 32 isn't your issue, it doesn't cause your car to quit, it is just monitoring your LTFT's, I would suggest getting the car scanned before jumping to any conclusions, only way to know what is really going on.
    I may appear to be nice, but don't be fooled, I probably don't like you

  5. #5
    eat-quattro-sleep PRY4SNO's Avatar
    Join Date
    Jul 2007
    Location
    Edmonton
    Posts
    1,883

    Default Re: Replaced MAF now car dies and gives EPC light... What gives?

    Quote Originally Posted by nothing77 View Post
    Block 32 isn't your issue, it doesn't cause your car to quit, it is just monitoring your LTFT's, I would suggest getting the car scanned before jumping to any conclusions, only way to know what is really going on.
    Sure thing, any suggestions on some specific blocks I could log though, while I'm at it?

    I have one friend with a VAG COM but our work schedules don't match up often so I want to make the most of it when time allows.
    Last edited by PRY4SNO; 02-06-2010 at 01:04 PM.
    Find me on Instagram @pry4sno

    Candy White 2010 VW Golf Sportwagen TDI 6 speed /// #farmenwagen
    Indigo Pearl Effect 1992 80q 20v /// Eventual AAN'd Winter Sled
    Brilliant Black 1990 Coupe quattro /// Because Racecar

  6. #6
    General Bad Ass Mantis's Avatar
    Join Date
    Apr 2008
    Location
    Calgary
    Posts
    1,383

    Default Re: Replaced MAF now car dies and gives EPC light... What gives?

    I would check 32 just to see your LTFT, no need to log it. I would consider logging the usual suspects like boost, timing, misfires. I wonder if your coolant temp sensor took a crap on you.
    I may appear to be nice, but don't be fooled, I probably don't like you

  7. #7
    Registered User p951's Avatar
    Join Date
    Jun 2006
    Location
    Calgary
    Posts
    172

    Default Re: Replaced MAF now car dies and gives EPC light... What gives?

    I've had that happen only while on cruise on my car ever since I've had it chipped. When it happens, you don't have to pull over or stop, just cycle the key and you're good to go again. Since I have a manual I don't even have to hit the starter, the car is in gear and just fires again, with no issue. As long as I don't use cruise, it never happens. I'd love to see if anyone gets a definitive way to fix this issue.

    The codes that are thrown are the ever so useful P1335 - torque monitoring 2 control limit exceeded. The three sensors that give inputs to that are the MAF, coolant temp sensor, and intake air temp sensor. All of those are within limits according to all the tests on my car.

    Hope that helps. If you find a fix, please share!
    1990 Porsche 951
    2013 Audi S4 6MT

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •